WordPress 3.2 gets HTML 5 support

Yesterday a WordPress patch improved HTML 5 compatibility by adding the following tags to the TinyMCE editor:

  • noscript, embed
  • menu, samp, header, footer, article, section, hgroup, nac, aside, details, summary, audio, canvas, command, datalist, figcaption, figure, keygen, mark, meter, output, progress, source, time, video, wbr

It also added some extra HTML colours and contains  some optimalisations.

This patch will not be applied in WordPress 3.1, so you will have to wait for WordPress 3.2.
Or use some haxx patching like I do.

Source: changeset #17625

One Reply to “WordPress 3.2 gets HTML 5 support”

Leave a Reply